# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{((?>[^{}]+|{(?1)})*)\}/$1/gm;t' <<< "\int_{1}^{2}\frac{x}{x/2}+{\frac{\sqrt{81}}{7x}}^7
\int x
\int_{19{} cz }^{2}{\frac{x}{x/2}+7}+7
(\int_{1}^{2}\frac{x}{x/2})/2"