import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{((?>[^\\{\\}]+|\\{(?1)\\})*)\\}";
final String string = "\\int_{1}^{2}\\frac{x}{x/2}+{\\frac{\\sqrt{81}}{7x}}^7\n\n"
+ "\\int x\n\n"
+ "\\int_{19{} cz }^{2}{\\frac{x}{x/2}+7}+7\n\n"
+ "(\\int_{1}^{2}\\frac{x}{x/2})/2";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}