# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{((?>[^{}]+|{(?1)})*)\}"
test_str = ("\\int_{1}^{2}\\frac{x}{x/2}+{\\frac{\\sqrt{81}}{7x}}^7\n\n"
"\\int x\n\n"
"\\int_{19{} cz }^{2}{\\frac{x}{x/2}+7}+7\n\n"
"(\\int_{1}^{2}\\frac{x}{x/2})/2")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.