const regex = /\{((?>[^{}]+|{(?1)})*)\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{((?>[^{}]+|{(?1)})*)\\}', 'gm')
const str = `\\int_{1}^{2}\\frac{x}{x/2}+{\\frac{\\sqrt{81}}{7x}}^7
\\int x
\\int_{19{} cz }^{2}{\\frac{x}{x/2}+7}+7
(\\int_{1}^{2}\\frac{x}{x/2})/2`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);