import Foundation
let pattern = #"\{((?>[^{}]+|{(?1)})*)\}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
\int_{1}^{2}\frac{x}{x/2}+{\frac{\sqrt{81}}{7x}}^7
\int x
\int_{19{} cz }^{2}{\frac{x}{x/2}+7}+7
(\int_{1}^{2}\frac{x}{x/2})/2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)