use strict;
my $str = '\\int_{1}^{2}\\frac{x}{x/2}+{\\frac{\\sqrt{81}}{7x}}^7
\\int x
\\int_{19{} cz }^{2}{\\frac{x}{x/2}+7}+7
(\\int_{1}^{2}\\frac{x}{x/2})/2';
my $regex = qr/\{((?>[^{}]+|{(?1)})*)\}/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";