re = /\{((?>[^{}]+|{(?1)})*)\}/m
str = '\\int_{1}^{2}\\frac{x}{x/2}+{\\frac{\\sqrt{81}}{7x}}^7
\\int x
\\int_{19{} cz }^{2}{\\frac{x}{x/2}+7}+7
(\\int_{1}^{2}\\frac{x}{x/2})/2'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result