using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/storage\/(\d+)\/articles\/pictures\/((?:[\S\s])*)";
string input = @"/storage/5/articles/pictures/1560534410321_a363bc0d804aec432567128ed10416ee.jpeg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}