package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/storage\/(\d+)\/articles\/pictures\/((?:[\S\s])*)`)
var str = `/storage/5/articles/pictures/1560534410321_a363bc0d804aec432567128ed10416ee.jpeg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}