re = /\/storage\/(\d+)\/articles\/pictures\/((?:[\S\s])*)/m
str = '/storage/5/articles/pictures/1560534410321_a363bc0d804aec432567128ed10416ee.jpeg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end