import re
regex = re.compile(r"\/storage\/(\d+)\/articles\/pictures\/((?:[\S\s])*)", flags=re.MULTILINE)
test_str = "/storage/5/articles/pictures/1560534410321_a363bc0d804aec432567128ed10416ee.jpeg"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")