use strict;
my $str = '/storage/5/articles/pictures/1560534410321_a363bc0d804aec432567128ed10416ee.jpeg';
my $regex = qr/\/storage\/(\d+)\/articles\/pictures\/((?:[\S\s])*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}