const regex = /\/storage\/(\d+)\/articles\/pictures\/((?:[\S\s])*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/storage\\\/(\\d+)\\\/articles\\\/pictures\\\/((?:[\\S\\s])*)', 'gm')
const str = `/storage/5/articles/pictures/1560534410321_a363bc0d804aec432567128ed10416ee.jpeg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}