#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<\s*span.+?class\s*=\s*"\s*booking-id-value\s*".*?>\s*([A-Za-z0-9]+)\s*<\/"
Local $sString = "foo" & @CRLF & _
"<span class="booking-id-value">U166097</span>" & @CRLF & _
"bar" & @CRLF & _
"<span style="some class="booking-id-value">U166097<p>this is not valid</p></span>" & @CRLF & _
"<span class="booking-id-value"> U166097</span>" & @CRLF & _
"<span class="booking-id-value">U166097@notvalid</span>" & @CRLF & _
"<span class ="booking-id-value" style="some">U166097</span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")