use strict;
my $str = 'foo
<span class="booking-id-value">U166097</span>
bar
<span style="some class="booking-id-value">U166097<p>this is not valid</p></span>
<span class="booking-id-value"> U166097</span>
<span class="booking-id-value">U166097@notvalid</span>
<span class ="booking-id-value" style="some">U166097</span>';
my $regex = qr/<\s*span.+?class\s*=\s*"\s*booking-id-value\s*".*?>\s*([A-Za-z0-9]+)\s*<\//p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}