const regex = /<\s*span.+?class\s*=\s*"\s*booking-id-value\s*".*?>\s*([A-Za-z0-9]+)\s*<\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*span.+?class\\s*=\\s*"\\s*booking-id-value\\s*".*?>\\s*([A-Za-z0-9]+)\\s*<\\\/', 'g')
const str = `foo
<span class="booking-id-value">U166097</span>
bar
<span style="some class="booking-id-value">U166097<p>this is not valid</p></span>
<span class="booking-id-value"> U166097</span>
<span class="booking-id-value">U166097@notvalid</span>
<span class ="booking-id-value" style="some">U166097</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}