// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<\s*span.+?class\s*=\s*"\s*booking-id-value\s*".*?>\s*([A-Za-z0-9]+)\s*<\/"#).unwrap();
let string = "foo
<span class=\"booking-id-value\">U166097</span>
bar
<span style=\"some class=\"booking-id-value\">U166097<p>this is not valid</p></span>
<span class=\"booking-id-value\"> U166097</span>
<span class=\"booking-id-value\">U166097@notvalid</span>
<span class =\"booking-id-value\" style=\"some\">U166097</span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}