import Foundation
let pattern = #"<\s*span.+?class\s*=\s*"\s*booking-id-value\s*".*?>\s*([A-Za-z0-9]+)\s*<\/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
foo
<span class="booking-id-value">U166097</span>
bar
<span style="some class="booking-id-value">U166097<p>this is not valid</p></span>
<span class="booking-id-value"> U166097</span>
<span class="booking-id-value">U166097@notvalid</span>
<span class ="booking-id-value" style="some">U166097</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)