$re = '/<\s*span.+?class\s*=\s*"\s*booking-id-value\s*".*?>\s*([A-Za-z0-9]+)\s*<\//';
$str = 'foo
<span class="booking-id-value">U166097</span>
bar
<span style="some class="booking-id-value">U166097<p>this is not valid</p></span>
<span class="booking-id-value"> U166097</span>
<span class="booking-id-value">U166097@notvalid</span>
<span class ="booking-id-value" style="some">U166097</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);