package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\s*span.+?class\s*=\s*"\s*booking-id-value\s*".*?>\s*([A-Za-z0-9]+)\s*<\/`)
var str = `foo
<span class="booking-id-value">U166097</span>
bar
<span style="some class="booking-id-value">U166097<p>this is not valid</p></span>
<span class="booking-id-value"> U166097</span>
<span class="booking-id-value">U166097@notvalid</span>
<span class ="booking-id-value" style="some">U166097</span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}