#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^StartWord\s*\K(?:\R(?!StartWord|StopWord).*)+"
Local $sString = "Delete this text De l e te this text" & @CRLF & _
"" & @CRLF & _
"StartWord" & @CRLF & _
"" & @CRLF & _
"Apples Oranges" & @CRLF & _
"Pears Grapes" & @CRLF & _
"" & @CRLF & _
"StopWord" & @CRLF & _
"" & @CRLF & _
"Delete this text Delete this text" & @CRLF & _
"" & @CRLF & _
"StartWord" & @CRLF & _
"" & @CRLF & _
"Peas Carrots" & @CRLF & _
"Peas Carrots" & @CRLF & _
"" & @CRLF & _
"StopWord" & @CRLF & _
"" & @CRLF & _
"Delete this text Delete this text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")