import re
regex = re.compile(r"^StartWord\s*\K(?:\R(?!StartWord|StopWord).*)+", flags=re.MULTILINE)
test_str = ("Delete this text De l e te this text\n\n"
"StartWord\n\n"
"Apples Oranges\n"
"Pears Grapes\n\n"
"StopWord\n\n"
"Delete this text Delete this text\n\n"
"StartWord\n\n"
"Peas Carrots\n"
"Peas Carrots\n\n"
"StopWord\n\n"
"Delete this text Delete this text")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")