re = /^StartWord\s*\K(?:\R(?!StartWord|StopWord).*)+/m
str = 'Delete this text De l e te this text
StartWord
Apples Oranges
Pears Grapes
StopWord
Delete this text Delete this text
StartWord
Peas Carrots
Peas Carrots
StopWord
Delete this text Delete this text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end