use strict;
my $str = 'Delete this text De l e te this text
StartWord
Apples Oranges
Pears Grapes
StopWord
Delete this text Delete this text
StartWord
Peas Carrots
Peas Carrots
StopWord
Delete this text Delete this text';
my $regex = qr/^StartWord\s*\K(?:\R(?!StartWord|StopWord).*)+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}