using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^StartWord\s*\K(?:\R(?!StartWord|StopWord).*)+";
string input = @"Delete this text De l e te this text
StartWord
Apples Oranges
Pears Grapes
StopWord
Delete this text Delete this text
StartWord
Peas Carrots
Peas Carrots
StopWord
Delete this text Delete this text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}