import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^StartWord\\s*\\K(?:\\R(?!StartWord|StopWord).*)+";
final String string = "Delete this text De l e te this text\n\n"
+ "StartWord\n\n"
+ "Apples Oranges\n"
+ "Pears Grapes\n\n"
+ "StopWord\n\n"
+ "Delete this text Delete this text\n\n"
+ "StartWord\n\n"
+ "Peas Carrots\n"
+ "Peas Carrots\n\n"
+ "StopWord\n\n"
+ "Delete this text Delete this text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}