const regex = /^StartWord\s*\K(?:\R(?!StartWord|StopWord).*)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^StartWord\\s*\\K(?:\\R(?!StartWord|StopWord).*)+', 'gm')
const str = `Delete this text De l e te this text
StartWord
Apples Oranges
Pears Grapes
StopWord
Delete this text Delete this text
StartWord
Peas Carrots
Peas Carrots
StopWord
Delete this text Delete this text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}