#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)simulate\(\w+, \[\n\s+\{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+},\n\s+\]\);"
Local $sString = " simulate(component, {" & @CRLF & _
" type: "click"," & @CRLF & _
" target: "[data-test-id=filterMenu-owner]"," & @CRLF & _
" });" & @CRLF & _
"" & @CRLF & _
" simulate(component, {" & @CRLF & _
" type: "click"," & @CRLF & _
" target: "[data-test-id=filterMenu-ownerUser]"," & @CRLF & _
" });" & @CRLF & _
"" & @CRLF & _
" simulate(filterMenuPopup, [" & @CRLF & _
" {" & @CRLF & _
" type: "click"," & @CRLF & _
" target: "[data-test-id=ownerGroup-item-8370094050639872]"," & @CRLF & _
" }," & @CRLF & _
" ]);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")