re = /simulate\(\w+, \[\n\s+\{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+},\n\s+\]\);/m
str = ' simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-owner]",
});
simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-ownerUser]",
});
simulate(filterMenuPopup, [
{
type: "click",
target: "[data-test-id=ownerGroup-item-8370094050639872]",
},
]);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end