import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "simulate\\(\\w+, \\[\\n\\s+\\{\\n\\s+type: \"(\\w+)\",\\n\\s+target: \"\\[data-test-id=([\\w-]+)\\]\",\\n\\s+\\},\\n\\s+\\]\\);";
final String string = " simulate(component, {\n"
+ " type: \"click\",\n"
+ " target: \"[data-test-id=filterMenu-owner]\",\n"
+ " });\n\n"
+ " simulate(component, {\n"
+ " type: \"click\",\n"
+ " target: \"[data-test-id=filterMenu-ownerUser]\",\n"
+ " });\n\n"
+ " simulate(filterMenuPopup, [\n"
+ " {\n"
+ " type: \"click\",\n"
+ " target: \"[data-test-id=ownerGroup-item-8370094050639872]\",\n"
+ " },\n"
+ " ]);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}