$re = '/simulate\(\w+, \[\n\s+\{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+},\n\s+\]\);/m';
$str = ' simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-owner]",
});
simulate(component, {
type: "click",
target: "[data-test-id=filterMenu-ownerUser]",
});
simulate(filterMenuPopup, [
{
type: "click",
target: "[data-test-id=ownerGroup-item-8370094050639872]",
},
]);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);