// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)simulate\(\w+, \[\n\s+\{\n\s+type: "(\w+)",\n\s+target: "\[data-test-id=([\w-]+)\]",\n\s+},\n\s+\]\);"#).unwrap();
let string = " simulate(component, {
type: \"click\",
target: \"[data-test-id=filterMenu-owner]\",
});
simulate(component, {
type: \"click\",
target: \"[data-test-id=filterMenu-ownerUser]\",
});
simulate(filterMenuPopup, [
{
type: \"click\",
target: \"[data-test-id=ownerGroup-item-8370094050639872]\",
},
]);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}