import re
regex = re.compile(r"simulate\(\w+, \[\n\s+\{\n\s+type: \"(\w+)\",\n\s+target: \"\[data-test-id=([\w-]+)\]\",\n\s+},\n\s+\]\);", flags=re.MULTILINE)
test_str = (" simulate(component, {\n"
" type: \"click\",\n"
" target: \"[data-test-id=filterMenu-owner]\",\n"
" });\n\n"
" simulate(component, {\n"
" type: \"click\",\n"
" target: \"[data-test-id=filterMenu-ownerUser]\",\n"
" });\n\n"
" simulate(filterMenuPopup, [\n"
" {\n"
" type: \"click\",\n"
" target: \"[data-test-id=ownerGroup-item-8370094050639872]\",\n"
" },\n"
" ]);")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")