# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:<)(?<=<)(\\/?\w*)(?=.*(?<=<\\/html))(?:>)/<$1>/gm;t' <<< "\"<Message text=\"<html>Welcome User, <br> Happy to have you. <br>.</html>\"
\"<Message text=\"<html>Welcome User, <br> Happy to have you. <br>.</html>\">
\"<Message text=\"<html>Welcome User, <br> Happy to have you. </html>\" Multi=\"false\"> <Meta source=\"system\" dest=\"any\"></Meta></Message>\"
\"<Message text=\"<html>Welcome User, <br> Happy to have you. </html>\" Multi=\"false\"> <Meta source=\"system\" dest=\"any\"></Meta></Message>\"
"