const regex = /(?:<)(?<=<)(\/?\w*)(?=.*(?<=<\/html))(?:>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<)(?<=<)(\\\/?\\w*)(?=.*(?<=<\\\/html))(?:>)', 'gm')
const str = `"<Message text="<html>Welcome User, <br> Happy to have you. <br>.</html>"
"<Message text="<html>Welcome User, <br> Happy to have you. <br>.</html>">
"<Message text="<html>Welcome User, <br> Happy to have you. </html>" Multi="false"> <Meta source="system" dest="any"></Meta></Message>"
"<Message text="<html>Welcome User, <br> Happy to have you. </html>" Multi="false"> <Meta source="system" dest="any"></Meta></Message>"
`;
const subst = `<$1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);