using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<)(?<=<)(\/?\w*)(?=.*(?<=<\/html))(?:>)";
string substitution = @"<$1>";
string input = @"""<Message text=""<html>Welcome User, <br> Happy to have you. <br>.</html>""
""<Message text=""<html>Welcome User, <br> Happy to have you. <br>.</html>"">
""<Message text=""<html>Welcome User, <br> Happy to have you. </html>"" Multi=""false""> <Meta source=""system"" dest=""any""></Meta></Message>""
""<Message text=""<html>Welcome User, <br> Happy to have you. </html>"" Multi=""false""> <Meta source=""system"" dest=""any""></Meta></Message>""
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}