# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<)(?<=<)(\/?\w*)(?=.*(?<=<\/html))(?:>)"
test_str = ("\"<Message text=\"<html>Welcome User, <br> Happy to have you. <br>.</html>\"\n\n"
"\"<Message text=\"<html>Welcome User, <br> Happy to have you. <br>.</html>\">\n\n"
"\"<Message text=\"<html>Welcome User, <br> Happy to have you. </html>\" Multi=\"false\"> <Meta source=\"system\" dest=\"any\"></Meta></Message>\"\n\n"
"\"<Message text=\"<html>Welcome User, <br> Happy to have you. </html>\" Multi=\"false\"> <Meta source=\"system\" dest=\"any\"></Meta></Message>\"\n\n")
subst = "<$1>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.