# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[aA][a-z]*n[a-z]*\b//gm;t' <<< "Abendessen Affen anders arrangieren Asien Arten Abend"