$re = '/\b[aA][a-z]*n[a-z]*\b/m';
$str = 'Abendessen Affen anders arrangieren Asien Arten Abend';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;