const regex = /\b[aA][a-z]*n[a-z]*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[aA][a-z]*n[a-z]*\\b', 'gm')
const str = `Abendessen Affen anders arrangieren Asien Arten Abend`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);