package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[aA][a-z]*n[a-z]*\b`)
var str = `Abendessen Affen anders arrangieren Asien Arten Abend`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}