// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[aA][a-z]*n[a-z]*\b").unwrap();
let string = "Abendessen Affen anders arrangieren Asien Arten Abend";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}