re = /\b[aA][a-z]*n[a-z]*\b/m
str = 'Abendessen Affen anders arrangieren Asien Arten Abend'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result