use strict;
my $str = 'Abendessen Affen anders arrangieren Asien Arten Abend';
my $regex = qr/\b[aA][a-z]*n[a-z]*\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";