#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*?)::=(.*?)"
Local $sString = "X::=___" & @CRLF & _
"Y::=||" & @CRLF & _
"E::=ss" & @CRLF & _
"|___|::=zvx" & @CRLF & _
"Z::=_" & @CRLF & _
"___||::=H" & @CRLF & _
"W::=im" & @CRLF & _
"_||_::=W" & @CRLF & _
"_||___::=E" & @CRLF & _
"H::=pre" & @CRLF & _
"I::=empt" & @CRLF & _
"|z::=i" & @CRLF & _
"x|::=e" & @CRLF & _
"||pre::=ive QI" & @CRLF & _
"Q::=att"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")