import re
regex = re.compile(r"(.*?)::=(.*?)", flags=re.MULTILINE)
test_str = ("X::=___\n"
"Y::=||\n"
"E::=ss\n"
"|___|::=zvx\n"
"Z::=_\n"
"___||::=H\n"
"W::=im\n"
"_||_::=W\n"
"_||___::=E\n"
"H::=pre\n"
"I::=empt\n"
"|z::=i\n"
"x|::=e\n"
"||pre::=ive QI\n"
"Q::=att")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")