// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*?)::=(.*?)").unwrap();
let string = "X::=___
Y::=||
E::=ss
|___|::=zvx
Z::=_
___||::=H
W::=im
_||_::=W
_||___::=E
H::=pre
I::=empt
|z::=i
x|::=e
||pre::=ive QI
Q::=att";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}