const regex = new RegExp('(.*?)::=(.*?)', 'gm')
const str = `X::=___
Y::=||
E::=ss
|___|::=zvx
Z::=_
___||::=H
W::=im
_||_::=W
_||___::=E
H::=pre
I::=empt
|z::=i
x|::=e
||pre::=ive QI
Q::=att`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}