using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)::=(.*?)";
string input = @"X::=___
Y::=||
E::=ss
|___|::=zvx
Z::=_
___||::=H
W::=im
_||_::=W
_||___::=E
H::=pre
I::=empt
|z::=i
x|::=e
||pre::=ive QI
Q::=att";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}