re = /(.*?)::=(.*?)/m
str = 'X::=___
Y::=||
E::=ss
|___|::=zvx
Z::=_
___||::=H
W::=im
_||_::=W
_||___::=E
H::=pre
I::=empt
|z::=i
x|::=e
||pre::=ive QI
Q::=att'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end